Resolved Issue with board connectivity across accounts and devices
Incident Report for monday.com
Resolved
Our team identified and resolved an issue with board connectivity across accounts and devices. The platform should now be functioning in a fully operational capacity. We appreciate your patience as we worked to resolve this.
Posted Jan 11, 2023 - 13:30 UTC
This incident affected: US (Platform).