Issues scrolling down in the item page overview/updates section

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 12:35 UTC

Identified

The team has identified the issue and is working on a fix.
Posted Feb 19, 2026 - 11:48 UTC

Investigating

Our team has identified the root cause of the issue and is working to resume regular service usage. We will continue to provide updates on their progress.
Posted Feb 19, 2026 - 10:23 UTC
This incident affected: EU (Communication).