Loading Issues with Older Browser Versions
Incident Report for monday.com
Resolved
Great news - monday.com is now fully operational, please make sure to refresh your browser to continue using the platform across all supported browsers with older versions!
Posted Feb 21, 2022 - 22:36 UTC
Monitoring
Our developers have implemented a fix for the issue causing the prolonged load/connectivity for older browser versions. Please refresh your browser page to confirm all is working again!
Posted Feb 21, 2022 - 22:12 UTC
Identified
We have identified an issue that is causing prolonged loading times with older browser versions. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Feb 21, 2022 - 17:41 UTC
This incident affected: US (Platform, Login / SSO, Notifications, Search, Automations, Integrations, API).