Form submission fail
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 11:12 UTC
Investigating
We are currently experiencing issues when submitting forms.
Posted Aug 16, 2023 - 10:09 UTC
This incident affected: EU (Other Functionalities).