Connectivity Issues across accounts and devices
Incident Report for monday.com
Postmortem

Earlier today we encountered an unusual amount of performance issues, and a brief downtime period at 13:37 UTC, which lasted around 3 minutes. This happened as a result of an undergoing software upgrade, which is meant to introduce improved performance and security related updates. During the process, we discovered a few unexpected bugs that, together with the added pressure on our infrastructure, resulted in the connectivity issues experienced. 

Our development team fixed the known issues and added the needed resources to stabilize the environment. 

We understand monday.com is crucial for your day-to-day work. We are truly sorry for any inconveniences caused today, and we’re devoting any necessary resources to improve and learn from this moving forward.

Posted Mar 22, 2021 - 20:38 UTC

Resolved
Great news - monday.com is now fully operational, please refresh your browser and try accessing the platform. If you can't immediately connect, please clear your cache and cookies, refresh your page and try again.
Posted Mar 22, 2021 - 14:04 UTC
Monitoring
We're already seeing improvements as our team works to resolve the connectivity issues. We hope to have good news for you very shortly!
Posted Mar 22, 2021 - 13:40 UTC
Identified
Things are looking up! Our R&D team has identified the issue and is now working on restoring consistent access to your monday.com account.
Posted Mar 22, 2021 - 13:40 UTC
Investigating
At the moment, we're experiencing connectivity issues for some accounts across all devices. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Mar 22, 2021 - 13:37 UTC
This incident affected: Platform, Login / SSO, Notifications, Search, Automations, Integrations, Activity Log, and API.