Investigating Issues with Purchasing Plans
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Apr 05, 2023 - 19:36 UTC
Update
Good news! The issue with our checkout page has been fully resolved.
Posted Apr 05, 2023 - 18:55 UTC
Investigating
Our developers have deployed a fix for the issue with our checkout page, and are monitoring the results. Please refresh your browser to access our checkout page, and thank you for your patience as we worked to solve this issue.
Posted Apr 05, 2023 - 18:39 UTC
Identified
The issue with our checkout page has been identified and our developers are working on a fix. Thank you for your patience!
Posted Apr 05, 2023 - 15:51 UTC
Investigating
We're currently experiencing issues with our checkout page, and users looking to purchase a monday.com plan may not be able to at the moment. We're investigating the issue and will update here as soon as possible. Thank you for your patience.
Posted Apr 05, 2023 - 15:46 UTC
This incident affected: US (Billing) and EU (Billing).