Investigating connectivity issues across accounts and devices
Incident Report for monday.com
Resolved
The platform is now back to regular service. Please refresh your browser to access the platform. Thank you for your patience
Posted Jan 22, 2024 - 17:48 UTC
Investigating
We are currently investigating reports of connectivity issues across the platform. Our team is working to resolve this promptly.
Posted Jan 22, 2024 - 16:15 UTC
This incident affected: US (Platform) and EU (Platform).