Identified the Issue affecting some users' ability to interact with files
Incident Report for monday.com
Resolved
The issue we were experiencing that impacted some users' ability to interact with files has been resolved. Please refresh your browser to return to stable usage of this aspect of the platform. If you happen to experience any further unexpected behavior, please reach out to us at support@monday.com!
Posted Mar 26, 2021 - 19:45 UTC
Identified
We have identified an issue impacting some users' ability to interact with files throughout the platform. Our developers are working to re-establish stable usage of this aspect of the platform. We promise to keep you updated with their progress.
Posted Mar 26, 2021 - 18:29 UTC
This incident affected: Platform.