Connectivity Issues across accounts and devices
Incident Report for monday.com
Postmortem

Yesterday, on July 12th, we experienced platform downtime, which affected our customers, reliant on our US servers, ability to login or fully access the platform.

The incident, which started at 10:01 am EST, was caused by a version update that we implemented on our server environment. 

Our R&D teams immediately worked to identify and resolve the root cause of the issue. At 10:19am, they applied a configuration fix to enable users to access monday.com as quickly as possible, while they continued to investigate so they could resolve the issue entirely. Some users may have experienced some reduced functionality during this phase. 

At 10:31 am EST, the exact cause of the issue was identified and a complete fix was issued. Our team continued to actively monitor the platform’s stability and by 10:55am EST, the problem was fully resolved and all aspects of the platform were behaving as expected.

There was no data loss or security risk.

We deeply apologize for any inconvenience caused by this incident as it is our utmost priority to provide a stable, exceptional experience on our platform. We know monday.com is critical to so many of our customers' businesses and we look forward to achieving incredible things together.

If you have any additional questions please reach out to our dedicated Customer Experience team at support@monday.com.

Posted Jul 13, 2022 - 15:36 UTC

Resolved
Great news - monday.com is now fully operational, please refresh your browser and try accessing the platform. If you can't immediately connect, please clear your cache and cookies, refresh your page and try again.
Posted Jul 12, 2022 - 15:21 UTC
Monitoring
We're already seeing improvements as our team works to resolve the connectivity issues. We hope to have good news for you very shortly!
Posted Jul 12, 2022 - 14:33 UTC
Identified
Things are looking up! Our R&D team has identified the issue and is now working on restoring consistent access to your monday.com account.
Posted Jul 12, 2022 - 14:32 UTC
Update
We are continuing to investigate this issue.
Posted Jul 12, 2022 - 14:26 UTC
Investigating
At the moment, we're experiencing connectivity issues for some accounts across all devices. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Jul 12, 2022 - 14:19 UTC
This incident affected: US (Platform, Login / SSO, Notifications, Search, Automations, Integrations, API).