Investigating issues with Search Everything

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 21:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 18, 2025 - 16:43 UTC

Investigating

We are currently experiencing issues causing delays in our Search Everything feature, specifically when searching for files, updates section posts, tags, teams, or groups. Our dedicated team is actively working to resolve this as quickly as possible.
Posted Jul 18, 2025 - 13:39 UTC
This incident affected: US (Search).