Investigating Issues with our Integrations

Incident Report for monday.com

Resolved

This issue with our integrations should be resolved now. Please refresh your browser, you should be able to return to your regular use of the services from there.
Posted 2 years ago. Feb 23, 2023 - 14:11 UTC

Investigating

At the moment, we're experiencing issues related to our integrations. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted 2 years ago. Feb 23, 2023 - 12:13 UTC
This incident affected: US (Integrations) and EU (Integrations).