Issues with duplicating boards and groups
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Jul 10, 2020 - 20:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2020 - 20:51 UTC
Identified
We have identified the cause of the issue and our developers are working to re-establish stable usage of this aspect of the platform. We promise to keep you updated with their progress.
Posted Jul 10, 2020 - 20:14 UTC
This incident affected: Platform.