Investigating issues with boards not loading
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Aug 18, 2024 - 07:52 UTC
Investigating
We are currently investigating reports of issues related to boards not loading. Our team is looking into this and will provide you with a response shortly.
Posted Aug 18, 2024 - 07:45 UTC
This incident affected: EU (Platform) and AUS (Platform).