Issues platform performance

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 16:46 UTC

Monitoring

Hi, team! We're experiencing issues with the platform performance, which is causing delays. We're monitoring the situation and will let you know as soon as we have any updates. Thank you for your understanding.
Posted Jul 01, 2026 - 16:32 UTC
This incident affected: US (Platform, Other Functionalities), EU (Platform, Other Functionalities), and AUS (Platform, Other Functionalities).