Identified issues with Activity Log latency

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 19:43 UTC

Identified

We are currently experiencing issues related to latency while loading new actions in the Activity Log. Our dedicated team is working to resolve this as quickly as possible. Please note that no data has been lost.
Posted Jun 26, 2025 - 15:10 UTC
This incident affected: US (Other Functionalities).