Issues with Apps Marketplace not loading in all regions is resolved.

Incident Report for monday.com

Resolved

The apps Marketplace loading issue has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Posted Jun 16, 2025 - 15:40 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 16, 2025 - 15:22 UTC

Monitoring

We had an issue with Apps Marketplace loading in all regions. Our team has released a fix for it and now are currently monitoring.
Posted Jun 16, 2025 - 15:12 UTC
This incident affected: US (Apps).