Investigating issues with delays in processing Mass Emails

Incident Report for monday.com

Resolved

The Mass Emails issue has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Posted Apr 29, 2026 - 12:55 UTC

Monitoring

We are currently investigating reports of issues related to delays in processing Mass Emails. While there is no data loss, users can expect delays of up to a few hours to see their Mass Emails in the Mass Emails Analytics menu and in their Sent folders in their inbox.
Posted Apr 28, 2026 - 14:11 UTC
This incident affected: EU (Emails & Activities).