Issues with creating sub-items and linked items

Incident Report for monday.com

Resolved

The issue has been successfully resolved. Thank you for your patience
Posted Aug 12, 2026 - 10:42 UTC

Monitoring

We're currently experiencing issues with creating sub-items and linking items.
Our developers have already identified the root cause, implemented a fix, and are monitoring results to ensure full system stability.
Posted Aug 12, 2026 - 10:38 UTC
This incident affected: US (Platform).