Issues with monday.com Workdocs
Incident Report for monday.com
Resolved
monday.com Workdocs experienced loading issues, and a fix was deployed. Please refresh your browser to regain access to monday.com Workdocs.
Posted Aug 01, 2023 - 17:09 UTC
Monitoring
monday.com Workdocs experienced loading issues. We identified the root cause and a fix was deployed.
Posted Aug 01, 2023 - 17:08 UTC
This incident affected: US (monday workdocs) and EU (monday workdocs).