Investigating connectivity issues across accounts and devices

Incident Report for monday.com

Postmortem

What Happened:

On June 12th (8:26 EST AM), we experienced a service disruption in our EU region that resulted in 68 minutes of degraded performance and 20 minutes of full downtime for several features, including API access, automations, notifications, and communications.

What caused it:

A backend infrastructure issue caused unexpected pressure on our caching systems, leading to widespread delays and partial outages across key services.

How we responded:

Our engineering teams quickly identified the root cause, rolled back the triggering changes, and scaled our systems to restore stability. Full functionality was gradually restored within a few hours.

What we're doing to prevent recurrence:

We’re implementing additional safeguards to detect anomalies earlier, improving system scalability, and strengthening internal processes to prevent similar incidents in the future

No data loss occurred during this incident.

We sincerely apologize for any disruption this caused to your workflow.

Thank you for your understanding as we work to continuously improve our platform's reliability.

Your team at monday.com

Posted 19 days ago. Jun 17, 2025 - 18:14 UTC

Resolved

The platform is now back to regular service. Please refresh your browser to access the platform. Thank you for your patience
Posted 24 days ago. Jun 12, 2025 - 15:09 UTC

Monitoring

A fix has been implemented, and we are monitoring results to restore full system stability
Posted 24 days ago. Jun 12, 2025 - 14:55 UTC

Update

Notifications should be working as expected now. Automations and integrations may still be delayed. We are continuing to work to fully resolve the issue
Posted 24 days ago. Jun 12, 2025 - 14:52 UTC

Update

Automations and integrations are up but may be delayed. We're still working to solve the issue with notifications. We appreciate your patience
Posted 24 days ago. Jun 12, 2025 - 14:38 UTC

Update

API should be working as expected now. We are continuing to work on a fix for the issues with automations, integrations, and notifications
Posted 24 days ago. Jun 12, 2025 - 14:07 UTC

Update

Automations, API, and notifications are still not working as expected. We're working to resolve the issues and will continue to provide updates on our progress
Posted 24 days ago. Jun 12, 2025 - 13:47 UTC

Update

The platform should be working mostly as expected. Our team is still working on issues with automations and notifications
Posted 24 days ago. Jun 12, 2025 - 13:28 UTC

Identified

Our team has identified the root cause of the issue and is working to resume regular service usage. We will continue to provide updates on their progress
Posted 24 days ago. Jun 12, 2025 - 13:20 UTC

Investigating

We are currently investigating reports of connectivity issues across the platform. Our team is working to resolve this promptly.
Posted 24 days ago. Jun 12, 2025 - 12:31 UTC
This incident affected: US (Platform) and EU (Platform).