Resolved issues with our Automations and Integrations
Incident Report for monday.com
Resolved
We've experienced a short delay (6 minutes at maximum) in processing our Automations and Integrations. This issue has been resolved and all triggers have been processed.
Posted May 04, 2020 - 06:15 UTC