Email to board feature and Email related issues in US

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted 2 years ago. Mar 24, 2023 - 06:04 UTC

Investigating

We're currently investigating issues with the Email to board feature on US server.
Posted 2 years ago. Mar 24, 2023 - 05:47 UTC