Investigating Issues with our homepage
Incident Report for monday.com
Resolved
This issue with our homepage should be resolved now. Please refresh your browser, you should be able to access the site from there.
Posted Mar 29, 2020 - 07:19 UTC
Investigating
At the moment, we're experiencing issues related to our homepage. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Mar 29, 2020 - 07:05 UTC
This incident affected: Homepage.