Investigating Issues with Processing Upgrades
Incident Report for monday.com
Resolved
This issue has now been resolved, thank you for remaining patient!
Posted Feb 21, 2021 - 13:01 UTC
Identified
We've identified the issue at hand, working with our third-party payment processor in order to restore our regular payments flow. We appreciate your patience!
Posted Feb 21, 2021 - 10:53 UTC
Investigating
We're currently experiencing issues with our billing flow, users looking to upgrade won't be able to at the moment. We're investigating the issue and will update as we progress. Thank you for your patience.
Posted Feb 21, 2021 - 10:46 UTC