Investigating issues with Logging In
Incident Report for monday.com
Resolved
The issue we were experiencing with our login issues has been resolved. Please refresh your browser to return to stable usage of this aspect of the platform.
Posted Mar 21, 2023 - 16:12 UTC
Investigating
At the moment, we're experiencing issues related to logging in to your account. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Mar 21, 2023 - 15:58 UTC
This incident affected: EU (Login / SSO).