Issues with boards failing to load
Incident Report for monday.com
Resolved
The issue with boards failing to load has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Posted Jun 10, 2024 - 08:20 UTC
Monitoring
A fix has been implemented and we are monitoring results to ensure full system stability.
Posted Jun 10, 2024 - 08:06 UTC
Update
We are continuing to investigate this issue.
Posted Jun 10, 2024 - 07:52 UTC
Investigating
We are currently experiencing issues related to boards loading. Our dedicated team is working to resolve this as quickly as possible
Posted Jun 10, 2024 - 07:44 UTC
This incident affected: US (Platform) and EU (Platform).