Connectivity issues across accounts on EU and AU servers

Incident Report for monday.com

Resolved

The issue with board creation, API, and Mass Emails has been resolved!
Posted Apr 27, 2026 - 10:15 UTC

Investigating

Our team has identified an issue with board creation, API, and Mass Emails. We are aware and actively working on a fix.
Posted Apr 27, 2026 - 09:45 UTC
This incident affected: EU (Platform).