Issues with platform not loading (Automations, AI features, Boards, Workspaces and other features).

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 17:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2026 - 17:14 UTC

Update

We are continuing investigating the issues related to platform not loading/working. This is also affecting automations, boards, board views, dashboards, AI features, my work, item creation, workspaces.
Posted Jul 07, 2026 - 16:40 UTC

Update

We are continuing investigating the issues related to platform latency/slowness. This also might affect automations not triggering/loading. Thanks for your patience and understanding.
Posted Jul 07, 2026 - 16:02 UTC

Investigating

We are currently experiencing issues related to platform latency/slowness. Our dedicated team is working to resolve this as quickly as possible
Posted Jul 07, 2026 - 15:45 UTC
This incident affected: US (Platform, Dashboards, Automations, Other Functionalities).