Investigating issues with our Updates Section
Incident Report for monday.com
Resolved
The issue we were experiencing with our Updates Section has been resolved. Please refresh your browser to return to stable usage of this aspect of the platform
Posted Nov 18, 2022 - 21:16 UTC
Monitoring
We have identified the cause of the issue and our R&D team is working to re-establish stable usage of this aspect of the platform.
Posted Nov 18, 2022 - 19:36 UTC
Investigating
At the moment, we're experiencing issues related to our Updates Section. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Nov 18, 2022 - 19:17 UTC
This incident affected: EU (Platform, Other Functionalities) and US (Platform, API, Other Functionalities).