Investigating Issues with Our Blog and Help Center
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Oct 30, 2023 - 20:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2023 - 20:27 UTC
Investigating
At the moment, we're experiencing issues related to our Blog and Help Center due to a 3rd party interruption. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Oct 30, 2023 - 20:24 UTC
This incident affected: US (Other Functionalities) and EU (Other Functionalities).