Investigating issues with our form submissions
Incident Report for monday.com
Resolved
The form submission issue has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Posted Jan 16, 2025 - 17:06 UTC
Investigating
We are currently investigating reports of issues related to our form submissions. Our team is looking into this and will provide you with a response shortly.
Posted Jan 16, 2025 - 16:39 UTC
This incident affected: AUS (Other Functionalities), US (Other Functionalities), and EU (Other Functionalities).