Connectivity issues across platforms and devices
Incident Report for monday.com
Postmortem

Yesterday, on September 6th, we experienced platform disruption that affected customers reliant on our US and EU servers, and their ability to fully access the platform.

At 1:27 PM EST we experienced locks in our authentication service database, which caused an overload on services that are vital to our platform. Our R&D teams immediately worked to identify and resolve the cause of the issue. 

By 1:50 PM EST, we had identified the root cause of the lock and immediately began deploying a fix. Users may have experienced complete downtime between 1:50-1:53 PM while the fix was being applied. 

We also applied further preventative measures to ensure the issue won’t occur again.

Our team continued to actively monitor the platform’s stability and the problem was fully resolved and all aspects of the platform were behaving as expected.

There was no data loss or security risk.

We’re incredibly concerned by any disruption to your work caused by temporary platform instability and we’re deeply sorry for any inconvenience. We’re committed to providing our customers with an exceptional experience on monday.com and know it’s critical to your business. It’s our utmost priority. 

If you have any additional questions or concerns, please reach out to our dedicated Customer Experience team at support@monday.com.

Posted Sep 07, 2022 - 11:47 UTC

Resolved
We are back up and operating, root cause is fixed.
Posted Sep 06, 2022 - 19:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 06, 2022 - 18:31 UTC
Update
We are back up and operating, identifying root cause
Posted Sep 06, 2022 - 18:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 06, 2022 - 18:10 UTC
Update
We are continuing to investigate this issue.
Posted Sep 06, 2022 - 17:55 UTC
Update
At the moment, we're experiencing connectivity issues for some accounts across all devices. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Sep 06, 2022 - 17:53 UTC
Investigating
We are currently investigating this issue.
Posted Sep 06, 2022 - 17:42 UTC
This incident affected: EU (Platform) and US (Platform, Login / SSO, Notifications, Search, Automations, Integrations, API).