Investigating reports of connectivity issues across some accounts
Incident Report for monday.com
Postmortem

Yesterday, February 14th at 8:52am EST, some of our US server customers experienced intermittent platform availability issues, due to a change in infrastructure aiming to improve system resilience.  There was no data loss or security risk to our customers during this incident, and EMEA and APAC servers were not impacted by the platform access issue. 

Our R&D teams were proactively monitoring the platform whilst implementing the change and immediately fixed the issue, the platform was in recovery within 4 minutes.

Between 8:56am and 9:15am EST, some customers continued to experience platform slowness while the platform fully recovered. Our team continued to actively monitor the platform in the hours following.

While precautionary measures and preparations were taken during these changes, and our teams were on hand to quickly address any issues that could arise, regrettably we were unable to prevent the disruption. 

We are continuing to invest in the enhancement of our release process to create brand new safety nets and automated safeguards that will create a safer environment for us to simultaneously ensure stability and invest in infrastructure improvements. 

We know that over the past 2 weeks you may have experienced a couple of disruptions, including an issue on February 8th due to a third party service failure. These recent incidents are not related to one another, and have each been resolved fully.

We want to assure you that we take this extremely seriously and all technical teams are completely focused on prioritizing stability, access and avoiding any disruption to your business.

If you need any additional account support, our dedicated Customer Experience team will be happy to help you and can be reached via the help center here

Posted Feb 15, 2024 - 15:45 UTC

Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 14:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2024 - 14:00 UTC
Investigating
Our team is investigating reports of connectivity issues. We are actively working on this and will keep you updated with further details as soon as they become available.
Posted Feb 14, 2024 - 13:54 UTC
This incident affected: US (Platform) and EU (Platform).