Issue with Board Creation on Non-English Interface
Incident Report for monday.com
Resolved
Our developers have released a fix to the issue and it should be resolved.
Posted Nov 16, 2022 - 15:10 UTC
Identified
Accounts on our non-english interface may be experiencing issues with new board creation. Our developers have identified the issue and are working diligently to resolve it. We appreciate your patience as we work to restore full functionality, and in the interim, changing the platform interface to English should restore board creation capabilities.
Posted Nov 16, 2022 - 14:16 UTC
This incident affected: EU (Platform) and US (Platform).