Issues accessing our support page
Incident Report for monday.com
Resolved
Great news - support.monday.com is now fully operational, please refresh your browser and try accessing the page.
Posted Sep 30, 2021 - 18:36 UTC
Investigating
At the moment, we're experiencing issues for some users when accessing our support page at monday.com/support. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Sep 30, 2021 - 07:45 UTC
This incident affected: US (Platform, Login / SSO, Notifications, Search, Automations, Integrations, Activity Log, API) and Support.