Investigating issues with our localized pricing pages
Incident Report for monday.com
Resolved
This incident has been resolved. The pricing pages are back online.
Posted Nov 20, 2019 - 23:19 UTC
Identified
We've identified the issue with our pricing pages and a fix is being implemented.
Posted Nov 20, 2019 - 22:50 UTC
Investigating
At the moment, we're experiencing issues related to our localized pricing pages. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Nov 20, 2019 - 22:41 UTC
This incident affected: Homepage.