Connectivity issues across accounts
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Jun 20, 2024 - 08:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2024 - 07:45 UTC
Investigating
We are currently investigating reports of connectivity issues across the platform. Our team is looking into this and will provide you with a response shortly.
Posted Jun 20, 2024 - 07:44 UTC
This incident affected: US (Platform) and EU (Platform).