Monitoring slowness across accounts and devices
Incident Report for monday.com
Resolved
The platform is now back to regular service. Please refresh your browser to access the platform. Thank you for your patience
Posted Jan 16, 2024 - 18:41 UTC
Monitoring
We are experiencing slowness across the system. We're working to restore full system stability.
Posted Jan 16, 2024 - 18:14 UTC
This incident affected: US (Platform) and EU (Platform).