My Work is temporarily down

Incident Report for monday.com

Resolved

My Work is up and running! Please refresh your browser to return to stable usage of this aspect of the platform. If you happen to experience any further unexpected behavior, please reach out to us at support@monday.com!
Posted 2 years ago. Aug 16, 2023 - 14:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 2 years ago. Aug 16, 2023 - 14:16 UTC

Investigating

At the moment, My Work is disabled as we're experiencing issues related to its performance. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted 2 years ago. Aug 16, 2023 - 12:52 UTC
This incident affected: US (Other Functionalities).