Delay in the Activity Log

Incident Report for monday.com

Resolved

The issue causing a delay in the activity logs has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience.
Posted May 12, 2026 - 01:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 11, 2026 - 22:27 UTC

Investigating

Our team has identified an issue causing a delay in the activity logs affecting events for both items and board logs. We are working to resolve this as quickly as possible.
Posted May 11, 2026 - 12:50 UTC
This incident affected: EU (Search).