Identified issues with accessing Workforms
Incident Report for monday.com
Resolved
The issue with accessing Workforms has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience!
Posted 4 days ago. Feb 04, 2025 - 14:45 UTC
Monitoring
A fix has been implemented and we are monitoring results to ensure full stability with automations.
Posted 4 days ago. Feb 04, 2025 - 14:30 UTC
Identified
Our team has identified the root cause of the issue in accessing Workforms and is working to resume regular service usage. We will continue to provide updates on our progress.
Posted 4 days ago. Feb 04, 2025 - 14:18 UTC
This incident affected: AUS (Other Functionalities), US (Other Functionalities), and EU (Other Functionalities).