We are experiencing issues with reaching our support team via email
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Aug 16, 2021 - 15:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2021 - 14:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 16, 2021 - 14:31 UTC
Investigating
We are experiencing issues with reaching our support team via email (support@monday.com). If you need to reach out to our support team, please do so via the help center in the meantime.

In the event that you do not have a monday.com account, please contact us via the below form.
https://monday.com/contact-us#form

We are doing our best to investigate and resolve this issue as fast as possible.
Posted Aug 16, 2021 - 14:24 UTC
This incident affected: US (Support).