monday.com homepage 404 error

Incident Report for monday.com

Resolved

Our monday.com homepage is up and running! You can continue navigating through our website with normality.
Posted 2 years ago. Oct 12, 2023 - 08:14 UTC

Investigating

Our platform is fully functional but our team is currently investigating 404 error in our monday.com homepage and diligently working to solve this.
Posted 2 years ago. Oct 12, 2023 - 08:03 UTC
This incident affected: US (Platform).