Investigating reports of some customers not being able to view some items

Incident Report for monday.com

Resolved

There was an issue with some customers not being able to view some items. There was no data loss and the issue is now resolved.
Posted Apr 24, 2024 - 10:12 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 24, 2024 - 10:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2024 - 09:53 UTC

Investigating

We’re currently experiencing issues with some customers not being able to see items in some accounts. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Apr 24, 2024 - 09:16 UTC
This incident affected: US (Platform), EU (Platform), and AUS (Platform).