Latency issues with Emails and Activities

Incident Report for monday.com

Resolved

The Emails and Activities issue has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience!
Posted 16 days ago. Apr 17, 2025 - 19:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 16 days ago. Apr 17, 2025 - 19:31 UTC

Investigating

We are investigating reports of latency issues with Emails and Activities. Our team is looking into this and will provide you with a response shortly.
Posted 16 days ago. Apr 17, 2025 - 19:19 UTC
This incident affected: AUS (Emails & Activities), US (Emails & Activities), and EU (Emails & Activities).