Investigating issues with our Activity Log
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 08:24 UTC
Update
We are continuing to investigate this issue.
Posted Aug 24, 2020 - 08:06 UTC
Update
We are continuing to investigate this issue.
Posted Aug 24, 2020 - 07:35 UTC
Investigating
At the moment, we're experiencing issues related to our Activity Log. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Aug 24, 2020 - 07:28 UTC
This incident affected: Activity Log.