Investigating issues with our Forms
Incident Report for monday.com
Resolved
The issue we were experiencing with our Forms has been resolved. Please refresh your browser to return to stable usage of this aspect of the platform. If you happen to experience any further unexpected behavior, please reach out to us at support@monday.com!
Posted Mar 20, 2023 - 18:01 UTC
Identified
At the moment, we're experiencing issues related to our Forms. Unrestricted forms require users to authenticate to view them. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Mar 20, 2023 - 16:16 UTC
This incident affected: US (Other Functionalities) and EU (Other Functionalities).