Monitoring issues with delays in our automations

Incident Report for monday.com

Resolved

The issue with delays in our automations has been successfully resolved. Please refresh your browser to resume regular service usage. Thank you for your patience!
Posted Nov 10, 2025 - 10:43 UTC

Monitoring

A fix has been implemented, and we are monitoring results to ensure full stability with automations delays.
Posted Nov 10, 2025 - 10:18 UTC
This incident affected: EU (Automations).