Issues with automations

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted 16 days ago. Jun 04, 2025 - 15:02 UTC

Investigating

We are currently experiencing issues related to automations, specifically with creating updates and email loops being sent. Our dedicated team is working to resolve this as quickly as possible
Posted 16 days ago. Jun 04, 2025 - 14:09 UTC
This incident affected: US (Automations), EU (Automations), and AUS (Automations).