Issues loading boards across accounts and devices
Incident Report for monday.com
Resolved
Great news - monday.com is now fully operational, please refresh your browser and try accessing the platform. If you can't immediately connect, please clear your cache and cookies, refresh your page and try again.
Posted Jun 28, 2021 - 21:16 UTC
Monitoring
Our team has implemented a fix and we're monitoring the results.
Posted Jun 28, 2021 - 21:05 UTC
Identified
We have identified the issue impacting some users' ability to interact with boards. Our developers are working to re-establish stable usage of this aspect of the platform. We promise to keep you updated with their progress.
Posted Jun 28, 2021 - 17:41 UTC
Investigating
At the moment, we're experiencing issues loading boards for some accounts, across all devices. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Jun 28, 2021 - 17:01 UTC
This incident affected: Platform, Login / SSO, Notifications, Search, Automations, Integrations, Activity Log, and API.